Welcome

Top Next

Welcome to the Ultimate Pet Editing Manual. This manual has been compiled from the excellent information and tutorials written by Carolyn Horn of Carolyn's Creations. Visit her website by clicking the link below. There are loads of tutorials, information and breeds at this site! A must visit!

carolynlogo
Click here to visit Carolyn's Creations


Contact the Author

Previous Top Next

You can contact Carolyn Horn, the author of the tutorials and text used to build this manual at the following location:
hex-help@hornsc.clara.co.uk

You can contact Nick Sherlock, the person who compiled this manual at the following location:
N_sherlock@ihug.co.nz


Editing Methods Introduction

This section covers the basics in getting access to the LNZ file in the breed that you want to edit. The LNZ file is text that tells the game what your breed looks and acts like, so this is the file that you want to edit if you're hexing a pet!

Check out the individual topics in this section to look at different methods of editing.

When you understand how to open the LNZ file, move on to the "LNZ Section" topic to learn exactly what the contents of the file mean.


LNZ Pro

LNZ Pro is a tool developed by Nicholas Sherlock to make LNZ editing quick and easy. It doesn't have the same problems with crashing or corruption that Resource Hacker does. You can download it from Carolyn's site on Nicholas' tools page.

Once you've downloaded it, run it and click File->Open. Select your breed. A window will pop up which asks you which LNZ file to edit. For example, the dalmation contains both "DM" and "DMPUP". The DM file is the description of the adult dalmation, so choose this one and click "Edit". You'll end up with a view like this:

lnzpromain

Edit the file as you normally would. You can use the "Tools->Check for errors" function to have LNZ Pro point out simple mistakes in your breed for you, or use "Tools->Reformat lines" to line up numbers in neat columns.

When you're done editing the file, click File->Save to write your changes back into the file.


Resource Hacker

Resource Hacker is a tool developed to let you edit "Resources" inside files. In breeds, these resources include sounds, LNZ files, behaviour .SCP files, adoption centre pictures and more. You can download Resource Hacker from http://www.users.on.net/johnson/resourcehacker/. To get to the LNZ file with Resource Hacker, follow these instructions:

Open Resource Hacker.

Click File->Open. Next to "Files of type", choose "All files (*.*)" like the picture below:

resopen
Double click on your .dog or .cat file to open it. You'll get a window like this:

resmain

This breed has two LNZ files, the "DM" file is the adult version, the "DMPUP" file is the puppy version. Choose the "DM" version. Edit the file at the right of the screen. When you're done, click "Compile Script", then choose "File->Save" to save your changes.

Resource Hacker sometimes crashes or corrupts your LNZ file, so always make a backup!


Ball Numbers

Here's a list of the ball numbers you will be working with in Dogz:

0 L ankle
1 L eyebrow1
2 L eyebrow2
3 L eyebrow3
4 L ear1
5 L ear2
6 L ear3
7 L elbow
8 L eye
9 L finger1
10 L finger2
11 L finger3
12 L foot
13 L hand
14 L iris
15 L jowl
16 L knee
17 L nostril
18 L shoulder
19 L hip
20 L toe1
21 L toe2
22 L toe3
23 L wrist
24 R ankle
25 R eyebrow1
26 R eyebrow2
27 R eyebrow3
28 R ear1
29 R ear2
30 R ear3
31 R elbow
32 R eye
33 R finger1

34 R finger2
35 R finger3
36 R foot
37 R hand
38 R iris
39 R jowl
40 R knee
41 R nostril
42 R shoulder
43 R hip
44 R toe1
45 R toe2
46 R toe3
47 R wrist
48 Belly
49 Butt
50 Chest
51 Chin
52 Head
53 Jaw
54 Neck
55 Nose (bottom)
56 Snout
57 Tail1
58 Tail2
59 Tail3
60 Tail4
61 Tail5
62 Tail6
63 Tongue1
64 Tongue2
65 Z-trans
66 Z-orient

And in Catz:

0 ankleL,
1 ankleR,
2 belly,
3 butt,
4 cheekL,
5 cheekR,
6 chest,
7 chin,
8 earL1,
9 earL2,
10 earR1,
11 earR2,
12 elbowL,
13 elbowR,
14 eyeL,
15 eyeR,
16 fingerL1,
17 fingerL2,
18 fingerL3,
19 fingerR1,
20 fingerR2,
21 fingerR3,
22 handL,
23 handR,
24 head,
25 hipL,
26 hipR,
27 irisL,
28 irisR,
29 jaw,
30 jowlL
31 jowlR,
32 kneeL,
33 kneeR,
34 knuckleL,
35 knuckleR,
36 neck,
37 nose,
38 shoulderL,
39 shoulderR,
40 snout
41 soleL (i.e. the foot),
42 soleR (i.e. the foot),
43 tail1 (nearest to the butt),
44 tail2,
45 tail3,
46 tail4,
47 tail5,
48 tail6 (tip),
49 toeL1,
50 toeL2,
51 toeL3,
52 toeR1,
53 toeR2,
54 toeR3,
55 tongue1,
56 tongue2,
57 whiskerL1
58 whiskerL2,
59 whiskerL3,
60 whiskerR1
61 whiskerR2,
62 whiskerR3,
63 wristL,
64 wristR,
65 zorient,
66 ztrans,


Colors

In LNZ files, colors are referred to by using a number such as 200 (Which means white in Petz).

Here are all of the available colors in Petz 2/3/4/5:

petzpal

Here are all of the available colors in Babyz:

babyzpal

Here are all of the available colors in Oddballz:

oddballzpal

Here are all of the available colours in Dogz1:

dogz1pal

Here are all of the available colours in Catz1:

catz1pal


X,Y,Z co-ordinates

When you're working in sections like Add Balls, Moves, etc, you'll come across "x y z" columns. These columns tell the game the 3-dimensional co-ordinates of where you want your ball to be positioned. For example:

[Move]
;Base ball x y z
14, 4, -3, -5

If you picture the pet looking out of the screen at you:

The X co-ordinate moves your ball to the pet's left (a smaller or more negative number) or right (larger or more postive number). If you're not sure which left and which right I mean, just experiment a little.

The Y co-ordinate moves it up (a smaller or more negative number) or down (larger or more postive number)

The Z co-ordinate moves it further out of the screen towards you (a smaller or more negative number) or back away from you (larger or more postive number)

axisfront axistop


LNZ Section Introduction

The LNZ file is text that tells the game what your breed looks and acts like, so this is the file that you want to edit if you're hexing a pet! Look at the "Editing methods" topic to find out how to access the LNZ file that you wish to edit, or get right into it and start looking at the "Breakdown" section which explains which each section means.


Important notes

1. For the section headings in the [ ] brackets, you really really need to take care that you have your lower and uppercase letters exactly as in the game's originals, because otherwise the game will either ignore the section, or crash, or produce something weird like the "robo-dog" effect.

2. Whatever is in the breedfile's .LNZ sections will override the equivalent sections in the Dogmaster.lnz or Catmaster.lnz; Similarly there are items not even in the "master" .lnz files, but apparently created somewhere in the engine, which we can enter into our breed's .lnz and control!

3. Don't forget that a breed actually contains two .LNZ sections -- okay, the poodle and Alley cat have four, but the extras are only for a different kind of variation. The point I'm making is that each breedfile has an adult .lnz and a puppy or kitten .lnz. Where there are sizes, fuzz amounts, or defaults etc listed in the puppy/kitten, if you change a ball size or fuzz or default etc in the adult only, it will not show up in the puppy or kitten.

4. Just about anything in a .lnz file can be given a set of variations. If you take care with the format (look at the Variations topic) you can "link" all the variations together if you wish, as well as linking adult variations to variations within the puppy or kitten's .lnz.

5. The information in these topics also holds true for Babyz .LNZ files and Oddballz .LNZ files; although they might look a little different at first glance, the same basic structure holds good for them also. Babyz has more ballz, a Polygons section, and more limited behaviours, and Oddballz has other extra Key Texts as well as exciting emoticons options and behaviours; that's really the only difference for the hexer.


Variations

In any area of the .LNZ (this goes for default scales, sounds pointers, texture lists -- any area!) you can make as many variations as you wish. When your pet is adopted, the game will pick a random mix of these variations to display. The normal kind of variation set goes like this, starting with a # number and then counting downwards to the ##:

#3
< data for this variation>
#2
< data for this variation>
#1
< data for this variation>
##

When you leave one of the variatons blank, like this, where you see that #3 has no data:

#3
#2
< data for this variation>
#1
< data for this variation>
##

The blank, or data-less, one will use the defaults. You need this if you have ball colour variations under [Color Info Override], because if you don't have one blank variation # in there then your [Ballz Info] colours won't show.

Now, if you want to make variations within the [Paint Ballz] area, just start putting variations in after any items that you want not to vary (such as the paw pads which are usually there). So you'd have all the paw pad lines of data, or any other non-variable lines of data, and then you would start on your series of variations. In the Dalmatian you can see that the game can pick from a whole load of different sets of variations, but you don't need to be as complex as that. Say you want four variations of spots on the snout, each a different size and colour, including one with no spot at all. It could look like this:

#4
#3
56, 70 -.8, -.8, -1 35 (etc -- rest of line of data)
#2
56, 90 -.8, -.8, -1 15 (etc -- rest of line of data)
#1
56, 50 -.8, -.8, -1 65 (etc -- rest of line of data)
##

Right, this is just a straight set of variations. But perhaps you want a set of red patches on a black dog, but orange patches on a white dog and white patches on a fawn dog, and never the other way around. For this you need to bring in the "linking" system. This is simple, but a lot of people get it wrong.

Say your [Ballz Info] contains the black dog data. Your [Color Info Override] should be laid out like this:

#3.A
#2
<white dog balls numbers and colours>
#1
<fawn dog balls numbers and colours>
##

Now go to your [Paint Ballz] section and put in a set of variations like this:

#3.A
<red patches data> (will go only on black dogs)
#2
<orange patches data> (will go only on white dogs)
#1
<white patches data> (will go only on fawn dogs)
##

And there you have it -- a set of linked variations.


Body Part Introduction

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Body Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Extra Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Extra Head Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Head Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Jowlz Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Left Arm Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Left Brow Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Left Ear Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Left Foot Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Left Hand Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Left Leg Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Right Arm Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Right Brow Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Right Ear Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Right Foot Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Right Hand Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Right Leg Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Tail Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Whisker Balls]

[Body Balls], [Extra Balls], [Extra Head Balls], [Head Balls], [Jowlz Balls], [Left Arm Balls], [Left Brow Balls], [Left Ear Balls], [Left Foot Balls], [Left Hand Balls], [Left Leg Balls], [Right Arm Balls], [Right Brow Balls], [Right Ear Balls], [Right Foot Balls], [Right Hand Balls], [Right Leg Balls], [Tail Balls], [Whisker Balls]

This lot is extremely useful in Oddballz, and at the Adoption Centre in petz it can have excellent results; you can use it to list, say, a tail ball under [Head Balls] in order to use that ball in a complex nose creation, along with the [Move] and [Project Ball] sections.

Unfortunately, in Petz, once you have adopted a pet and get it out of the door in the game, the ball remains in the place that you have given it in [Move] -- but as soon as the pet turns its head, the ball doesn't turn along with it. You might enjoy the effects of course, creating petz that look right at some angles but then suddenly disassemble themselves when they move, so here they are for your amusement. I'll show you the [Head Balls] with a typical listing for a cat; you would use the others in exactly the same way, listing the actual ballz that should be in those areas of the body and then continuing the list with any which wouldn't normally be there (such as the tail, under the head).

[Head Balls]
4
5
7
8
9
10
11
14
15
24
27
28
29
30
31
37
40
57
58
59
60
61
62


[Add Clothing]

Example:
[Add Clothing]
#3.C
; kind toy_dll lnz file
Hat "\Resource\Clothes\Pink Bow.clo" "\art\Sprites\Toyz\Clot_HatBowPink\Clot_HatBowPink.clz"
#2
Hat "\Resource\Clothes\Pink Bow.clo" "\art\Sprites\Toyz\Clot_HatBowPink\Clot_HatBowPink.clz"
#1
##

This section is only needed if you want some pets to come out of the Adoption Centre wearing a specified clothing item such as hats, bows, etc, which stand outside the pet's own ballz.

To add clothes to a pet which comes out of the Adoption Centre, decide which of the two types of clothing the choesn item is (Flat or Add). Then put into the file [Flat Clothing] or [Add Clothing]. Then, you can find out what the .lnz (.clz) for the given item of clothing is either by looking inside the .clo file or (a little easier perhaps) by putting the item on some pet, closing the game, and looking in the .pet file for the string art\Sprites\Toyz\

Take the case of Glasses, you would have the "kind" is Glasses (you find that defined inside the Glasses file), the "toy_dll" is the .clo file Glasses.clo in your clothes directory, and the "lnz file" is Clot_Glasses.clz:

[Add Clothing]
; kind toy_dll lnz file
#2.A
Glasses "\Resource\Clothes\Glasses.clo" "art\Sprites\Toyz\Clot_Glasses\Clot_Glasses.clz"
#1
##


[Adjust Clothing]

Example:
[Adjust Clothing]
; kind: Shirt,Pant,Sock_FrontL,Sock_FrontR,Sock_BackL,Sock_BackR,Tail,Hat,EarringL,EarringR,NoseThing,Glasses
; kind offset scale (floating point, 1.0 is no change in size)
Hat 0,0,0 0.8

You only need this section -- and to change it -- if some item of clothing doesn't look right on the breed.

Choose from the list of items shown for the "kind" column.

The offset is the x,y,z co-ordinates relative to where the clothing item sits normally, so that you can shift it to a different position. Check out the co-ordinates tutorial.

The scale allows you to make it look bigger or smaller.


[Flat Clothing]

Example:
[Flat Clothing]
; kind: Shirt,Pant,Sock_FrontL,Sock_FrontR,Sock_BackL,Sock_BackR,Tail,Hat,Hat2,EarringL,EarringR,NoseThing,NoseThing2,Glasses
; kind toy_dll lnz file
#8.0;sweater, red
Shirt "\Resource\Clothes\Red Sweater.clo" "\art\Sprites\Toyz\Clot_SweaterRed\Clot_SweaterRed.clz"
#7
Shirt "\Resource\Clothes\Red Sweater.clo" "\art\Sprites\Toyz\Clot_SweaterRed\Clot_SweaterRed.clz"
(etc)

This section is only needed if you want some pets to come out of the Adoption Centre wearing a specified clothing item such as shirts, socks, pants; things which cover the pet's ballz closely, rather than standing outside them.


[Head Rotation Limits]

The Head Rotation Limits and Head Tilt Limits sections set the limits, just as they say, and they are usually in the "master" .lnz files. You can put them into your breed as with all these [ ] key texts, and the game will do as you say :-)

[Head Rotation Limits]
-50, 50

[Head Tilt Limits]
-40, 45


[Head Shot]

Example:
[Head Shot]
0 frame number
19 rotation
0 roll
4 tilt
-21 head rotation
2 head tilt
17 head cock
43, 43 R / L eyelid height
23, 23 R / L eyelid tilt
0, 0 (X, Y) eye target

This section is only meaningful in the pet's adoption centre picture. They do not have a noticeable effect on the actual pet. They can all be altered, and you can get some flexible or inflexible results by changing the amount of head rotation, or tilt allowed. Some difference can be made in the way the eyelids look, too. You can actually make your pet's picture look totally different from the pet itself -- an intriguing but useless thought. (For Oddballz users, this is the same idea as the [Get Info], which is an animation loop that plays in the "Get Info" dialog box.)


[Head Tilt Limits]

The Head Rotation Limits and Head Tilt Limits sections set the limits, just as they say, and they are usually in the "master" .lnz files. You can put them into your breed as with all these [ ] key texts, and the game will do as you say :-)

[Head Rotation Limits]
-50, 50

[Head Tilt Limits]
-40, 45


Rendering Options Introduction

Now, these are fun. I found them ages ago but hadn't realised that most people didn't know that they could put these in and have a laugh with them, so here they are now. You can put all or some of these into your .lnz, and change the numbers beneath. This is how I made my wireframe calicos; I changed the [Circle Render Mode] and [Line Render Mode] to 2.

Fool around with these numbers and the [Draw Linez Before Ballz] to get some very spectacular results -- I won't detail them out here because hey, you guys need to have some fun surprises to enjoy ;-)

[Draw Linez Before Ballz]
1

[Circle Render Mode]
0

[Line Render Mode]
0

[Default Glue Ball]
6

[Z Shade Slope]
100

[Draw Small Balls]
1


[Circle Render Mode]

Now, these are fun. I found them ages ago but hadn't realised that most people didn't know that they could put these in and have a laugh with them, so here they are now. You can put all or some of these into your .lnz, and change the numbers beneath. This is how I made my wireframe calicos; I changed the [Circle Render Mode] and [Line Render Mode] to 2.

Fool around with these numbers and the [Draw Linez Before Ballz] to get some very spectacular results -- I won't detail them out here because hey, you guys need to have some fun surprises to enjoy ;-)

[Draw Linez Before Ballz]
1

[Circle Render Mode]
0

[Line Render Mode]
0

[Default Glue Ball]
6

[Z Shade Slope]
100

[Draw Small Balls]
1


[Default Glue Ball]

Now, these are fun. I found them ages ago but hadn't realised that most people didn't know that they could put these in and have a laugh with them, so here they are now. You can put all or some of these into your .lnz, and change the numbers beneath. This is how I made my wireframe calicos; I changed the [Circle Render Mode] and [Line Render Mode] to 2.

Fool around with these numbers and the [Draw Linez Before Ballz] to get some very spectacular results -- I won't detail them out here because hey, you guys need to have some fun surprises to enjoy ;-)

[Draw Linez Before Ballz]
1

[Circle Render Mode]
0

[Line Render Mode]
0

[Default Glue Ball]
6

[Z Shade Slope]
100

[Draw Small Balls]
1


[Draw Linez Before Ballz]

Now, these are fun. I found them ages ago but hadn't realised that most people didn't know that they could put these in and have a laugh with them, so here they are now. You can put all or some of these into your .lnz, and change the numbers beneath. This is how I made my wireframe calicos; I changed the [Circle Render Mode] and [Line Render Mode] to 2.

Fool around with these numbers and the [Draw Linez Before Ballz] to get some very spectacular results -- I won't detail them out here because hey, you guys need to have some fun surprises to enjoy ;-)

[Draw Linez Before Ballz]
1

[Circle Render Mode]
0

[Line Render Mode]
0

[Default Glue Ball]
6

[Z Shade Slope]
100

[Draw Small Balls]
1


[Draw Small Balls]

Now, these are fun. I found them ages ago but hadn't realised that most people didn't know that they could put these in and have a laugh with them, so here they are now. You can put all or some of these into your .lnz, and change the numbers beneath. This is how I made my wireframe calicos; I changed the [Circle Render Mode] and [Line Render Mode] to 2.

Fool around with these numbers and the [Draw Linez Before Ballz] to get some very spectacular results -- I won't detail them out here because hey, you guys need to have some fun surprises to enjoy ;-)

[Draw Linez Before Ballz]
1

[Circle Render Mode]
0

[Line Render Mode]
0

[Default Glue Ball]
6

[Z Shade Slope]
100

[Draw Small Balls]
1


[Line Render Mode]

Now, these are fun. I found them ages ago but hadn't realised that most people didn't know that they could put these in and have a laugh with them, so here they are now. You can put all or some of these into your .lnz, and change the numbers beneath. This is how I made my wireframe calicos; I changed the [Circle Render Mode] and [Line Render Mode] to 2.

Fool around with these numbers and the [Draw Linez Before Ballz] to get some very spectacular results -- I won't detail them out here because hey, you guys need to have some fun surprises to enjoy ;-)

[Draw Linez Before Ballz]
1

[Circle Render Mode]
0

[Line Render Mode]
0

[Default Glue Ball]
6

[Z Shade Slope]
100

[Draw Small Balls]
1


[Z Shade Slope]

Now, these are fun. I found them ages ago but hadn't realised that most people didn't know that they could put these in and have a laugh with them, so here they are now. You can put all or some of these into your .lnz, and change the numbers beneath. This is how I made my wireframe calicos; I changed the [Circle Render Mode] and [Line Render Mode] to 2.

Fool around with these numbers and the [Draw Linez Before Ballz] to get some very spectacular results -- I won't detail them out here because hey, you guys need to have some fun surprises to enjoy ;-)

[Draw Linez Before Ballz]
1

[Circle Render Mode]
0

[Line Render Mode]
0

[Default Glue Ball]
6

[Z Shade Slope]
100

[Draw Small Balls]
1


Scales and Extensions introduction

The various Scales and Extensions sections make basic changes to the shape of your pet. Extreme values can make a very funny looking pet, but don't pass on well to second generation pets.


[Body Extension]

Example:
[Body Extension] // pixels
0

As with the Face Extension; not the best way to make very large changes to the length of a pet. Much better to use extra Add Ballz of a suitable size, and Linez.


[Default Scales]

Example:
[Default Scales]
150 normal pet scale
145 normal ball scale

Now, what we have here are two numbers which between them control the size of the pet and the way the ballz are balanced in the pet.

Obviously if these two numbers are small, the pet will be small and if large, the pet will be large. The ratio between these two scales is actually quite important; if the pet scale is very small -- say, 4 -- and the ball scale is large -- say, 100 -- then you will get a cute ball coming out of the AC. If it's the other way around, you will get a strange ghostly skeleton of a pet. 0 and 0 gets you total invisibility...

But as regards 2nd-gens, you want to be careful with these. If you have sizes less than 75 and 75 in your adult's [Default Scales], the game will tend to make the baby's adult stage default to 75 and 75. For kitten and puppy .LNZ files, you can go as low as 45 and 45 or 48 and 48, and the game will pass it on to 2nd-gens, just as it does with Lilliputz. So you can get a 2nd-gen which has a kitten/puppy stage which has the [Default Scales] of 45/45 and which grows up to the [Default Scales] of 75/75. Similarly, if you make your breed have [Default Scales] of greater than 170 and 170, it will force 2nd-gens to be smaller.


[Ear Extension]

Example:
[Ear Extension] // percentage
90

This extends the end ball of the ear away from the head by a percentage of the default.


[Face Extension]

Example:
[Face Extension] // pixels
-8

A very large minus number such as -50 can make the pet's nose stick out of the back of the head; a very large plus number can make it jut forward a long way. The downside of this is that not all the ballz extend forward or back with the nose, and when the head moves things can apparently slice through the linez which join nose to head.


[Feet Enlargement]

Example:
[Feet Enlargement] // percentage
105 // total foot extension
0 // Similar to head, vector expansion vs. ball size increase balance

Please tell me that this is obvious to you -- please? As it says, it's similar to the way the [Head Enlargement] works.


[Head Enlargement]

Example:
[Head Enlargement]
110 // percent enlargement
0 // vector expansion vs. ball size increase balance

Altering these two numbers relative to each other makes the head various different shapes. For instance, if you use 10 and 10, you end up with something that looks a bit like the head of a praying mantis. If you use 200 and 100, you end up with a large but well-proportioned head. If you use 100 and 10, the head looks swollen and the eyes squidged together. 110 and 0 is pretty normal.


[Leg Extension]

Example:
[Leg Extension] // pixels
-3 // front leg
-3 // hind leg

This is where you can make your pet hunch down a little at the back, or have the front of its body closer to the ground. The point here is that you can extend the back legs relative to the front, or vice versa, or lift the whole pet further from the ground, etc. As with all these "extension" and "enlargement" sections, there is a limit to how much you can change the numbers and have the pet look right.


[256 Eyelid Color]

Example:
[256 Eyelid Color]
35, 2

The first number is the eyelid colour, and the second number appears to behave very like a "group" number. You should find this useful in solving some 2nd-gen problems, with eyelids always reverting to grey or black.


[Add Ball Override]

If you wanted to override ballz 95 and 96, you could do it thus:

[Add Ball Override]
95 75 99 20
96 88 88 20

The first column is the ball number and the next three are the x,y,z co-ordinates. May be useful in variations if you don't want to use the [Omissions] and you only care about the positioning of the ball. Note that if you add any further columns they aren't picked up by the pet -- at least, in my game they aren't.


[Add Ball]

Example:
[Add Ball]
;base x y z color otlnCol spckCol fuzz group outline ballsize bodyarea addGroup texture

The [Add Ball] is brilliant, you can make just about any shape you want, using this section. You can build a whole breed on just one base ball, omitting all the others (as with the fishie), or you can make your babies very different from your adults, just by fiddling with this section.

Note that there is a "hidden" extra column, which you always see in dogz' extra tongue ball:

63, 0, 0, 0, 1, 0, 0, -1, -1, -1, -1, 0, 0, 1, 63

If this is not put in there, the middle ball of the tongue appears to be missing. This was the error that StudioMythos made with the Pug's tongue. (To clarify this further; the reason why there was an apparent gap is that the ball size is too small to be seen, at size "0", unless its size is shown relative to a ball number listed in that extra colmn. If the ball size had been something like 20, then it would have appeared just fine. This isn't the only reason that it's good to put tongue ball 63 in that extra column, as I show below, but it's a major reason why there was a gap in the Pug's tongue).

So, for Add Ball ballz that you wish to behave in a special way relative to a particular ball, put the relevant base ball number in that column. My spiders' legs, for instance, would not work right if I didn't have connections like this for the lower legs:

38, 0, 10, 60, 39, 79, 0, -1, 3, 0, 26, 1, 0, -1,
12, 0, 0, 60, 39, 79, 0, -1, 3, -1, -10, 1, 0, -1, 12
63, 0, -5, 60, 39, 79, 0, -1, 3, -1, -10, 1, 0, -1, 63
63, 0, 0, 60, 39, 79, 0, -1, 3, 0, -10, 1, 0, -1, 22

Note that this extra number also makes a difference to the size of the ball. It helps greatly, if you want your ball to be exactly the same size as the base ball (useful sometimes, really). Just put the "relative" ball in that column and then 0 in the ballsize column. As with the paint Ball section, it's a kind of scale hack, but also as I say above, a behaviour hack. Very handy.

;base x y z color otlnCol spckCol fuzz group outline ballsize bodyarea addGroup texture
2, 3, -12, -258 55 0 0 0 -1 -1 50 0 1 -1

Most of the columns are really self-explanatory, but some need a bit of extra understanding. The easy ones are:

Base -- The base ball that you want your added ball to be positioned relative to.

X Y and Z -- The 3-dimensional co-ordinates of where you want your ball to be positioned relative to the base ball. Check out the co-ordinates tutorial here.

Color -- The colour of the ball. Note that colours 0-9 inclusive and 150 upwards are "opaque" and will not allow textures to show.

otlnCol -- the ball's outline colour. Any colour other than black will usually not pass on to 2nd-gens (apart from the iris outline colours if you've designated any [Add Ball] ballz to be irises with the [Eyes] command)

spckCol -- Speckle colour; this is not noticeable in Petz II-5, but is very important in catz 1 and dogz 1. In those original games, Speckles were the only way of getting some kind of texture onto a pet.

Fuzz -- Well, fuzz. -1 is no fuzz, 3 is quite a lot of fuzz.

outline -- Thickness of outline. As with [Ballz Info] ball outlines, you can specify a more minus number than -1; for instance, -2 will produce a "relief-map" effect, making the ball appear to stand proud, without giving it the harsh solid-outline effect that you would get with the positive thickness of 2.

ballsize -- Ball, err, ah, how can I put it? Size. Yes, that should do it -- LOL!

texture -- The texture which goes on the ball, and you use the [Texture List] here just as with [Ballz Info] ballz. -1 means no texture, 0 means the first texture in the Texture List 1 means the second texture in the list, etc.

The three columns which confuse people most are: group, bodyarea, and
addGroup:

group -- As with the [Ballz Info] section, this controls certain properties of the ball, including how the pet takes paint from the paint brush and how ball properties continue on into 2nd-gens. You would use this in conjunction with [Fur Color Areas] to force pets to pass on certain traits.

bodyarea -- This is important when it comes to 2nd-gens and linez joining properly. To make sure that a 2nd-gen will pick up your linez properly, you need to make sure that all the balls that are to be joined have the same bodyarea, and if they are to be joined to a base ball, they need to have the same bodyarea as that ball. I don't have a list of bodyareas, but a good rule of thumb is that, if the ball is to be a head ball or near the head, use bodyarea 8 and for others, 1 is a pretty good catch-all. Don't use 0 because that tells the game to use defaults that it chooses. NOTE: I gather that Butterfly Chaser has put together a useful list of Bodyarea numbers which should be very helpful to people who end up with 2nd-gen double-tail problems when cross-breeding.

addGroup -- This is the column which, in Oddballz, would enable certain emoticons to pop up at certain moments. In Petz these emoticon notations don't seem to work, but if you put 1 here the ball will appear at moments of excitement (as with my mystery-emoticon petz) and if you put 0 it is visible all the time.

NOTE 1 -- you need to know what number of ball your [Add Ball] ball is if you want to join it to other ballz with [Linez]. It's pretty simple really; just count down the lines of your added ballz, starting with ball number 77 which we are so conveniently told is the start of the animator's (that's us, folks!) addballz. Ignore all lines which start with a semi-colon -- ; -- because the game ignores them too. Just count each line of data as a new add ball, and keep a note. When I make complex breedz, I put little commented notes (starting with a semi-colon so that I can read them but the game can't) to say where I am in the added ballz numbers, and these notes can be very handy.

NOTE 2 -- Variations. People have a lot of trouble with variations, and part of what goes wrong happens in 2nd-gens. The problem is caused by the fact that some hexers put their added-ball variation # numbers in [Add Ball], which is really the only section that doesn't handle them predictably. Think about it; the [Add Ball] section sets the game to counting extra balls, and that count can so easily go wrong if you use variations here. There are two solutions; either include the _whole_ [Add Ball] section in each variation (as you would with variations in the [Ballz Info] section) -- a clumsy solution that would make the .lnz file _huge_ in some complexly varied breedz. Or you can handle it neatly and reliably in [Omissions]. Put every single ball that you might wish to have into [Add Ball], keep a note of the ball numbers which you do not wish to have in any given variation, and then list those unwanted ballz in a variation set, or series of variation sets, under [Omissions].

NOTE 3 -- you can make your kitten/puppy grow extra limbs or change shape and colour by clever manipulation of the [Add Ball] section. I have shown rough examples of how this works in my Duckoddz and Butterflie breedz, and then I helped Vickie to make it work on those charming ravens of hers, and of course my frogoddz are making full use of the technique. This is how I do the trick:

For the fluffy-duckling effect
==============================
In the adult .LNZ, in [Add Ballz], I put the extra fluff ballz and I make them very small. I make a note of which ball-number each extra added ball is by the usual method of counting down the lines of added ball data.

In the "kitten" or "puppy" .LNZ, I pop those ball-numbers into the [Ball Size Override] section, putting each ball number on a new line with a space between it and the size that I want the ball to be.

The babies will come out with the big fluffy balls, and they will gradually disappear as the baby grows up as if the pet is moulting its baby-down.

For the wings and legs-growing effect
=====================================

As before, in the adult .LNZ, in [Add Ballz], I put in all the extra ballz that I want. I make the baby's fluff balls very small and I make the wings (or other extensions) how I want them to look in the adult.

Now I take the adult [Add Ballz] section and paste that into the kitten or puppy area, complete and untouched. Now here comes the bit that you need to get right, or it'll be very frustrating. The number of ballz in this [Add Ballz] section needs to be the exact same number as in the adult [Add Ballz]. Try adding in an extra one or removing one, and your whole puppy/kitten add ball data will simply be disregarded by the game.

Right, there are only some things that can be changed between the two; but the important things are these: The ball size and the ball position. It is much better to use this method for ball position than, say, [Move], because you can sometimes get unpredictable results (crashes etc) if you list added ballz in [Move].

You will now find that the baby comes out as you wish, and will grow delicately into a fully-fledged adult.

Limits to added ballz allowed in a breed
========================================

Now that Add Ballz are being used so extensively in the more complex new breedz, it seems that we are at last coming up against a limit to what the game can take. Butterfly Chaser, trying to make detailed leaves on her tree, is the first to have come up against a limit which she found to be 510. I've done some testing, and in the chihuahua base breed that I tried, I found the limit of added ballz allowed to be 445, including the 10 hidden "utility addballz".

So along with the [Ballz Info] section, my game will accept a total of 512 balls (this does not include Paint Ball ballz, which are a different type). It may be that it varies slightly between breedz, but it's more likely that we went cross-eyed counting the lines and we may either or both have got the exact number wrong :-) But the point is, there is a limit and we need to be careful after we reach 500 total ballz.

Any add-ball clothing item, such as a hat or glasses, adds to this count and therefore _will_ crash the game when you try to clothe your pet. Paint ball clothing (shirts, pants etc) will _not_ cause crashes, as they don't count as extra ballz in the same way.

So the main point here is that if you want a breed that won't crash, make sure that you have less than 500 balls altogether between Add Ball ballz, [Ballz Info] ballz, and any addball clothing items that you want your pet to come out of the AC wearing. If you want to make sure that the breed won't crash even when wearing complicated clothing, then bring that quantity of balls down to something like 450.

Breedz made only of Add Ball Ballz...
====================

It's possible to make a breed entirely of add ball ballz only, using [Omissions] to omit all the original ballz 0-76 but, if you do that, you will not be able to pet the pet. You'll be able to pick it up and feed it etc, but not stroke it. I did toy with the idea of using that feature in my PFMice breed, since we are not able to stroke the original mice, but in the end I decided it was nicer to be able to do so, so I enabled some base ballz :-)


[Additional Frames]

Example:
[Additional Frames]
\ptzfiles\dog\dm\dm.bhd

This section tells the game where extra animation frames can be found. There is only one breed which has this, the dalmatian.


[Ball Size Override]

The first column is the ball number, and the second column is the size.
When you see this in the puppy or kitten .lnz, it's there to give your pup or kitten a different look from the adult.
When you see this in the adult .lnz, it's there to make variations.
NOTE: If it's in the adult section and you don't have a variation number with no data at all between it and the next variation number, then the [Ballz Info] ball sizes won't ever be able to show through for the listed ballz.

These different override sections can all be given "linking" variations, by which I mean a structure like this:

#3.A
#2
<data>
#1
<data>
##

and then they will all work together instead of producing random colours, groups, textures, fuzz, and sizes.

For anyone who wants to know how to make a petz breed to stay the same size and look like a puppy as an adult (but not look like the adult version of the breed), you need to take note of these overrides. First off, you need to make the various Defaults the same in pup and adult .LNZ files, but then you have two choices. You can either make the adult [Ballz Info] the size you wish and then delete the override sections in the puppy .lnz, or you can put all the defaults and size/fuzz overrides that are in the puppy .LNZ into the adult .LNZ also. Simplest way to do the latter is to overwrite the various default sections and then, above the [Ballz Info] section, put in a [Ball Size Override] section and enter the data below it exactly as you see it in the puppy section, without any variation # numbers. Also, if the puppy has [Fuzz Override], put that into the adult .LNZ in exactly the same way, with no variations.

Note that if there is already a [Ball Size Override] and / or a [Fuzz Override] in the adult .lnz, you will want instead to replace the data that's under them with your puppy's data and make sure that there are no variation # numbers. Your dog will look like a pup all its life. This works with catz/kittens too of course.

The thing to remember with these overrides is that they can be used in the adult section to give you variations -- or even to make the game ignore the relevant data in [Ballz Info] or [Add Ball] -- and in the puppy/kitten section to give a different effect for the babe or also to give it variations.


[Ballz Info]

[Ballz Info]
============
;FUZZ --> -1 = no outline, 0 = half outline, > 0 = outline thickness
;OUTLINE --> -1 = no outline, 0 = half outline, > 0 = outline thickness

in catz

;col outCol spklCl fuzz otlntTyp sizeDif group texture

in dogz

;col outCol spklCl fuzz otlntTyp sizeDif group texture ball#

I always thought that these columns were self-explanatory, but it appears that many people cannot figure out what the mnemonics mean.

col -- Ball colour Note that colours 0-9 inclusive and 150 upwards are "opaque" and will not allow textures to show.

outCol -- Outline colour of ball. Any colour other than black will usually not pass on to 2nd-gens, apart from the iris outline colours.

spklC -- Speckle colour, which has no appreciable effect in Petz II-5 but is vital in Catz 1 and Dogz 1.

fuzz -- Fuzziness. -1 is no fuzz, 0 is a little fuzzy, 3 is a lot fuzzy.

otlntTyp -- Outline thickness (or type). -1 means no outline, 0 means a dotted outline, greater than 0 means the thickness. As with [Add Ball] outlines, you can specify a more minus number than -1; for instance, -2 will produce a "relief-map" effect, making the ball appear to stand proud, without giving it the harsh solid-outline effect that you would get with the positive thickness of 2.

sizeDif -- Difference in size of ball from the default which the game would normally give to that ball in that breed. What this means is that if all the numbers in the sizeDif column were 0, they would still be the basic shape of balls for dogz or catz -- big round head, smaller ballz for tail, tiny ballz for ear tips and fingers etc. If you want a small head and one huge toe, you need to make the sizeDif for the head something like -25 and for the toe something like 20.

group -- This helps you to group together various ballz so that they share certain properties, notably the way they take paint from the paint brush and the way they pass colours and textures on to 2nd-gens. You would want to use this in conjunction with [Fur Color Areas] to force pets to pass on certain traits. Setting the group number to -1 will effectively make it "group-less" which will prevent changes from occurring in 2nd-gens and gets around problems with the game forcing "albinos" all the time. Unfortunately this also means that not even the mutations which breeders do want can occur.

texture -- The texture which goes on the ball, and you use the [Texture List] here just as with [Add Ball] ballz. -1 means no texture, 0 means the first texture in the Texture List, 1 means the second texture in the list, etc.

ball# -- this is only there in Dogz breedz and is simply the ball number.

In Catz, you then get a column of programming words such as eBall_ankleL, and these are not needed but are handy for us. In dogz you can see clearly that they are programmers' comments because they are commented - out with a semi-colon, as with ";L ankle"


[Breed Name]

Example:
[Breed Name]
Calico

Changing the breed name seems to make no appreciable difference, although it might possibly have some effect on 2nd-gens?


[Color Info Override]

This is where you put variations for ball colours.
NOTE: if you don't have a variation number with no data at all between it and the next variation number, then the [Ballz Info] colours won't ever be able to show through for the listed ballz.

If two columns, it's ball number and colour.
If three columns, it's ball number, colour, and group.
If four columns, it's ball number, colour, group and texture. Use the [Texture List] for the number you want, just as with [Add Ball] and [Ballz Info] sections.


[Default Linez File]

Example:
[Default Linez File]
\ptzfiles\dog\dm\dm.lnz

This section tells the game where the adult .lnz is to be found. You can put an appropriate .lnz onto the hard drive and redirect this url. You can of course do the same with the

[Default Linez File]
\ptzfiles\dog\dogmaster.lnz

or

[Default Linez File]
\ptzfiles\dog\catmaster.lnz

files, but there's not really much point in doing so with those because of course everything that you put into your breedfile's .lnz overrides the "master" .lnz defaults.


[Default Linez Thickness]

Example:
[Default Linez Thickness]
90

If the starting and ending thicknesses of a line aren't specified, then this is what the game will default to.


[Eyes]

Eyes and irises are really a special case, just as with dogz nostrils. They behave differently in various ways. Dogz nostrils, of course, are well known for having stubborn outlines which revert to black in 2nd-gens. In the case of irises, this doesn't happen of course, but they do have their own quirks, one of which is the fact that they will re-appear in 2nd-gens if you've only "removed" them by making them ultra-small. The eyelid is tied in with the eyes, and will only appear if there is a proper eye ball -- i.e. the eye ball has not been listed under [Omissions].

Another point to note is that listing the iris ball under [Omissions] does not actually remove it unless you also list the eye ball. If you want to keep the current eye ballz but have a different ball behave as iris, change the number of right and left iris under the [Eyes] Key Text, as described below; you don't need to change the eyes numbers as well as the iris numbers, but you do need to list in this section all four of the balls which you are going to use, if you're changing any of them.

Many hexers these days, with all the unusually-shaped breedz that are coming out, are having problems with 2nd-gen eyes appearing in odd places. They are puzzled, because they have the size at something like -999. Well, the game doesn't like that kind of thing for 2nd-gens. If you want your pet to be eyeless, then list the eye ballz under [Omissions]. If you want eyes that work and aren't all over the place in petz, then you need to "anchor" them suitably. There are two ways of doing this. The first is to re-assign the eye ballz to ball-numbers of your choice, usually add ballz. For instance, if you have created "blind" eyes from [Add Ball] Ballz 105, 106, 107 and 108 you would replace the eye and iris numbers with these in [Eyes]. The second is to use [Project Ball] to hold those eyes in place.

[Eyes]
15 14 RightEye/leftEye
28 27 RightIris/leftIris

for catz, or for dogz:

[Eyes]
32 8 RightEye/leftEye
38 14 RightIris/leftIris

This simply tells the game which ball numbers are the eyes and which are the irises. You can change these numbers to any that you wish, but remember that whatever ball you choose to put in there will become an eye or iris ball. LOL -- you can have lots of fun with this one. Remember that if you use add-ball eyes and don't list the originals under [Omissions], you'll end up with the cat or dog's original eye ballz staring sightlessly at you whilst the new eyes blink normally wherever you put them. Creepy :-)

I could have used add ball ballz here to give my boyz eyes, but in fact I chose a different way, instead tying the addball to the eye ball in [Project Ball] with the add ball in the first column, the eye ball in the second, and 0 distance in the third:

105 8 0
106 32 0

and for catz

105 14 0
106 15 0


[Force To Female]

This "Force" section lets you choose which variation comes out of the Adoption centre as female, and which as male. In this example, variations 3.C and 2 will always come out female, and variation 1 will always come out as male.

[Force To Female]
#3.C
1
#2
1
#1
0
##

[Force To Male]
#3.C
0
#2
0
#1
1
##

In this example, the pet will always be male

[Force To Male]
1

In this example, the pet will usually come out female but occasionally male

[Force To Female]
#4
1
#3
1
#2
1
#1
0
##


[Force To Male]

This "Force" section lets you choose which variation comes out of the Adoption centre as female, and which as male. In this example, variations 3.C and 2 will always come out female, and variation 1 will always come out as male.

[Force To Female]
#3.C
1
#2
1
#1
0
##

[Force To Male]
#3.C
0
#2
0
#1
1
##

In this example, the pet will always be male

[Force To Male]
1

In this example, the pet will usually come out female but occasionally male

[Force To Female]
#4
1
#3
1
#2
1
#1
0
##


[Fur Color Areas]

Example:
[Fur Color Areas]
; (1-4, 5 - jowls)
;FurColorTrait ballWithBaseColor colorAreas

As with all these sections, you can add it to your breedfile if it doesn't already exist in there. Put the header [Fur Color Areas] on one line and then, beneath it, list the "trait" number, then the ball with the base colour, and then all the colour areas which should be in this group. Some breedz have 0-7 colour areas listed in this section, and some, such as the Russian Blue or Calico cats, only 0-3. The Calico is interesting, because it only has one colorArea per FurColorTrait and ballWithBaseColor, whereas the Russian Blue has colorArea 0, 1, 2, 3 all in line with one FurColorTrait and ballWithBaseColor.

An interesting item in this section is shown in the Scottie breedfile, and only in that one as far as I can see:

; rampbase: only works currently with black balls
2 34 rampbase: 1 2

It's one of those things which, like the Dalmatian's [Additional Frames], doesn't seem to be of real use. The idea of "rampbase" as a term used in colour areas typically has to do with palettes; you would normally have a colour changing from one shade to another via a series of gradations, and the rampbase would be the start of this. In the Scottie breed under [Fur Color Areas], you will see the programmers' comment that the rampbase only works with black balls. Then they put the FurColorTrait 2 and the ballWithBaseColor 34, which is indeed black, and then there is the rampbase: 1 2. I have fiddled with this in the past but not seen any significant differences in either adoptions or new-borns. You may find it more useful, who knows :-)

You can make your 2nd-gens' ballz either usually pick up on the colours from your breedfile, or usually pick up on the mother's colour, if you manipulate this section. What you need to change varies depending on which basic P.F.Magic breed you used as a base, but I have found that altering the "group" number for a ball (in [Ballz Info] or [Add Ball]) to 1 and then changing the FurColorTrait number in [Fur Color Areas] to 2 (in Scotties) or 3 (in chihuahuas) will force the game to take the colours from the breedfile, while 4 (in Scotties) makes the game tend to pick the colours from the mother. Of course, changing the Group number has an effect on how a pet's ballz take paint from the paint-brush, and you may find that other numbers will work just fine. This is really just to show you what sort of thing with which you'll want to experiment.

If you simply cannot get the colours to pass on in some balls, then use whatever works best for the others and then put -1 as the group number for the stubborn balls (works both for [Add Ball] balls and [Ballz Info] balls). All the balls with -1 as their "group" will become un-paintable with the paint brush, so if that matters to you you'll have to either carry on trying to find the perfect group/fur colour area combination or accept some albino/bad colouring effects in your 2nd-gens.


[Fur Markings]

Example:
[Fur Markings]
; e_GroupType_Normal == 0, e_GroupType_BodyArea == 1, e_GroupType_Primary == 2, e_GroupType_Paw == 3
; groupType, balls/paintballs which logically constitue a single marking (if e_GroupType_BodyArea replace entire area, used esp. with dog ears)

This section is once again likely to be of use to breeders who want their petz to pick up on the correct markings, in this case particularly the paint patches, within the breedfile. Take a look at the structure of the [Fur Markings] section, and you should get some idea of how to build your own. You get some help from the programmers' comments here:

e_GroupType_Normal == 0,
e_GroupType_BodyArea == 1,
e_GroupType_Primary == 2,
e_GroupType_Paw == 3

This is pretty clear, I think, when you look at the two column headers:

groupType

and

balls/paintballs which logically constitue a single marking

The first column is the e_GroupType, and the basic type will be 0 or 1 or 2 or 3. 3 is there in all breeds that have this section, because all of them have paw pads. The breedz which don't have this listed are breedz which don't have any other ballz to list in this section, because the dogmaster.lnz or catmaster.lnz already have these listed. A typical example is the Dalmatian, which has this as the first [Fur Markings] line

3 9:0 10:0 11:0 13:0 33:0 34:0 35:0 37:0 44:0 45:0 46:0 36:0 20:0 21:0 22:0 12:0

and all of these are of course paw paint ballz. In fact, this may seem like a bit of overkill because, if a breed doesn't have the paw pads listed, it shouldn't really make a difference since they are in the Catmaster.lnz and Dogmaster.lnz. However, whatever you see in a breedfile actually overrides whatever is in the catmaster or dogmaster .lnz files, and if [Fur Markings] are listed without the line of paw markings, the game will not use the paw marking data from the "master.lnz" [Fur Markings] and your paw pads may mutate illogically.

Paint Ballz are listed here in <num1>:<num2> form, but don't let that panic you; it simply means that the particular base ball <num1> has one or more paint ballz attached to it. If you have only one for a baseball, the number is (for instance) 16:0. If you have more than one paint patch for one base ball, they go (for instance) 24:0 24:1 24:2 etc, counting up on the right-hand side of the : mark.

I have noticed that it is possible to have ballz in a given "paint ballz" line that don't actually have any mention in the [Paint Ballz] section, as with the Egyptian Mau and its sole/wrist balls 41, 42, 63, 64. I don't know if this is a StudioMythos error, or whether this has any real effect on 2nd-gens with this particular breed. It may be that it was an error that they didn't see, or didn't bother to fix, because the Egyptian Mau furfile is made to be opaque.

Breedz such as the Dalmatian, which in fact have a lot of [Paint Ballz], don't have all of these listed in the [Fur Markings] area. It would seem that this may be partly because the default dalmatian spots for the game are in fact black, so there is no 2nd-gen problem. This will most likely be why people have trouble with breeding Dalmatians which do not have black spots.

When numbers don't have the <num1>:<num2> form, they are just ball numbers from [Ballz Info] or [Add Ball], as opposed to [Paint Ballz]. This is illustrated rather well by this line from the Dalmatian's [Fur Markings]

1 28, 29, 30, 83, 85, 87

which means that for this breed, the right ear ballz (including the right-ear add ballz) have had to be listed together as groupType Bodyarea.

So, if you want to add your own [Fur Markings] area to a breed, or you want to make sure that you get your breed to be consistent in 2nd-gens with certain markings, list on a line the group type, and then the balls _or_ the paintballs which are to be grouped together for that type.


[Fur Pattern Balls]

Example:
[Fur Pattern Balls]
; addballs which are part of fur only
addballs: 92, 93, 94, 95, 96, 97, 98, 99, 100, 101, 102, 103 ; tail

These are used to control the Add Ball balls which are designed just to make fur patterns. So they are used for the Tabby cat's tail and leg stripes, and the Maine Coon's ruff, etc. If you look carefully, you'll see that these cosmetic ballz don't tend to have linez joining them to any ballz other than similarly non-structural ballz.

If you have problems with pets which have this kind of "cosmetic" addball breeding true, try making sure that you add [Fur Pattern Balls] and list them correctly under it. Note that the Great Dane has no such section, probably because the extra tail ballz are structurally a part of the tail, not a cosmetic addition. Note also that this section is intended to keep the colour of each "pattern ball" which is listed "true", which means that the tabby stripes will remain black when the rest of the cat mutates in colour. Conversely, the extra tail ballz of the Great Dane, which are _not_ listed, mutate with the rest of the tail. Get the idea?

Start each line with addballs: and then list the relevant add ballz, with commas between, and list each set of different body area ballz on a different line. See the tabby for example; the stripe ballz for the tail are all listed on one line, then on the next line the arm stripe ballz are listed, and so on.

So, basically: if the ballz that you are having trouble joining up in 2nd-gens are "cosmetic", i.e. they are supposed to join up with each other and not necessarily with any base (or "structural") ballz, then there is no need to worry about the "group" number, just add this section to your breedfile and list all the ballz which should go together on one line. If the ballz you are having this trouble with are not cosmetic but are part of the breed's structure, then you need to make use of the balls' "bodyarea" numbers, as mentioned in my 2nd-gen fixes under [Add Ball].


[Fuzz Override]

The first column is the ball number, and the second column the amount of fuzz you want this variation to have.

NOTE: if you don't have a variation number with no data at all between it and the next variation number, then the [Ballz Info] fuzz amounts won't ever be able to show through for the listed ballz.

The first column contains the ball number, and the second column contains the amount of fuzz.


[Key Balls]

This is how the Key Ballz are entered; For dogz:

[Key Balls]
52 head
50 chest
54 neck
53 jaw
63 tongue1
64 tongue2
51 chin
55 nose
49 butt
48 belly

for catz:

[Key Balls]
24 head
6 chest
36 neck
-1 jaw
55 tongue1
56 tongue2
-1 chin
37 nose
3 butt
2 belly

Now, as you can see, they've listed certain ballz here. -1 seems to mean "default". There's nothing to stop you from changing this list of key ballz, pretending to the game that the chest is the head key ball etc. In fact, if you want a good laugh, take a cat's .lnz and put the dogz' key ballz in there. Sit back and enjoy what comes out of the Adoption Centre :-)


[Linez]

Petz are made up of ballz and the linez which join them together. You can make almost any shape by careful positioning of ballz and linez.

; -1 mean use the associated ball color
; Only the first three fields need to be specefied
;srt end fuzz col lfCol rtCol sThck eThick
[Linez]

As the comment states, you only actually need to fill the numbers in the first three columns to make a line work, but in fact you can make good
use of the other columns to get the effect you're after.

srt -- The starting ball to which you wish to join another.

end -- The end ball to which you wish to join the starting ball
NOTE that if you are joining ballz from [Add Ball] with different "Bodyarea" numbers, the linez will not work for 2nd-gens.

fuzz -- The fuzziness of the line. This does not always pass on to 2nd-gens

col -- Colour of the line. If you put -1 here, the line will be the colour of the starting ball. The line colour will pass on to 2nd-gens.

lfCol -- Colour of the left outline of the line. Doesn't always pass on to 2nd-gens

rtCol -- Colour of the right outline of the line. Doesn't always pass on to 2nd-gens

sThck -- Thickness of the starting-ball end of the line The thickness is a percentage of the starting ball.

eThick -- Thickness of the end-ball end of the line. The thickness is a percentage of the end ball.
If you fiddle with the sThck and eThick numbers, you can get some useful effects, such as a unicorn-horn with a ball on the end of it. Also useful if you want to make a breed which looks like a skeleton, because you can have the ballz larger than the width of the linez.

It is possible to have two extra columns here, for which we have no handy headers. They appear to affect how the line looks, making it look more definite. The first extra column has to do with the outline, and the second one has to do with how the line is drawn, whether after the ball or before, and it usually comes out as 0 or 1. If it's 0, the ends of the line look as if they are tucked inside the ball. If it's 1, the ends of the line show up as if on the edge of the ball -- it's difficult to explain what I mean here, but basically you can see the squared outline of the end of the line if you choose 1. This passes on to 2nd-gens, by the way.

In Babyz, however, there seems to be more to it. It is possible to put a ball number in there under certain circumstances, and then it apparently has a relative-ball effect also. This does not appear to work in Petz, where any number greater than 1 apparently defaults back to 1 and -1 defaults back to 0.

NOTE -- the "laser-line" effect which you get when putting hats on some breedz is caused by having a line joining two balls, one of which does not exist. So if your last Add Ball is ball number 130, and you try to make a line which joins, say, ball 130 to 131, you'll get this happening. The simple solution is to remove the line from [Linez] of course.


[Little one]

Example:
[Little one]
dmpup.lnz

This tells the game which .lnz to use to make the pup or kitten. You can make your pet always adult or always a pup/kitten by making the [Little one] dm.lnz (or whichever it would be for the adult .lnz of your breed) and making sure that the data in the .lnz is the size and shape that you want. In fact, Babyz cheats and does exactly that with its [Little one], and I have suggested in my Babyz-editing "howto"s the method for getting around that and having your babyz grow.


[Lnz Version]

Example:
[Lnz Version]
2

This section tells the game which version the LNZ file is in, but changing it makes no difference. If another Petz game is released, this number may change to 3.


[Marking Factor]

I have never seen a pet which makes use of this. The idea is obviously that it helps control the markings on petz, but I have not found a syntax yet which makes any appreciable difference.


[Move]

Example:
[Move]
;face
14, 4, -3, -5
15, -4, -3, -5
27, 4, -3, -5
28, -4, -3, -5

Now, this section is very important to hexers and is often used in conjunction with [Project Ball] to get things like tail shapes right.

The first column is the ball number. The next three columns are the x, y, z axes to which you want your ballz to be moved relative to the defaults. Check out the co-ordinates tutorial here. If there is a fifth column, then that is the ball to which this move should be relative. So 14, 4, -3, -5 14 would mean that you want ball 14 to be moved sideways by 4, up by 3, and forward by 5 relative to its normal position.

This fifth column is also useful in helping to keep a ball "anchored"; it's not as firm as when you use the [Project Ball] distances as well-- for instance, angled legs in dogz breedz can throw out strangely if you don't keep them in place with a [Project Ball] "tie" -- but it does help to keep balls from behaving strangely. This [Move] thing will at least keep your ballz as intended relative to the "relative" ball.

This is actually quite a handy feature to be able to use when getting a ball to move within certain limits. For example, if you take one ball -- such as an tail or ear ball -- and give it a "move" position relative to a ball on one side, such as a hip or cheek, and then take it again and give it a "move" position relative to another ball, it will move within those constraints. If you want a laugh, try putting this into the [Move] area of a cat breed:

9, 30, 0, 0, 48
9, -30, 0, 0, 48
11, 60, 0, 0, 9
11, -90, 0, 0, 5

But of course that's just silly :-) A more sensible use of this technique is to keep the tail or ears moving within reasonable limits relative to stabilising ballz, or to keep other ballz in a stable relationship to other relevant ones.

If, say, you want your elbows to stay relevant to the shoulders, you do your xyz move for the elbows thus, in a catz breed:

12, <x>, <y>, <z>, 38
13, <x>, <y>, <z>, 39

In a dogz breed of course that would be:

7, <x>, <y>, <z>, 18
31, <x>, <y>, <z>, 42

Note, you'd have numbers where I've got <x>, <y>, <z> in the above example, of course!


[No Texture Rotate]

Example:
[No Texture Rotate]
-1

This is not as useful as it sounds. I've tried various numbers under this, and it looks as if 1 will stop the texture of ball 1 from rotating around itself so that, say, an apple picture disappears and you get a picture-join instead which rolls around the ball; but I have not found any number which prevents it from rolling around the ball itself. You may have better luck.

This explanation seems to have confused quite a few people. It's difficult to explain, but here goes anyway... What I'm thinking of is what happens when you pick up the pet. The pet rotates, and the texture on the ball in question stays in the same position relative to your hand instead of what I was hoping for, i.e the same position relative to the ball. I wanted to pick up a donkey and have the stripe along the back stay in the middle of the back while I picked it up.

So to give you more detail, if I put the number 0 in place of -1, the game will stop the texture from moving around itself within the left ankle ball. I pick up a leopard and the spot which was facing out of the screen at the time continues to face out of the screen all the time the pet is rotating, until it is set down. The texture has moved around the ball while the ball was turning, but the end result is that it looks the same after as before.

If I keep it as the example above, with -1 which is the default, it tells the game to use the default -- which is that the texture rotates loosely around the ball. I pick up the pet, and as it revolves, the texture moves around inside the ball so that some other splotch is facing out of the screen by the time I set the pet back down.

You can of course have any number of ballz listed under this, such as, for a cat whose body, shoulder, hip and cheek balls you want to have the treatment:

[No Texture Rotate]
2
3
4
5
6
25
26
38
39


[Num Ballz]

Example:
[Num Ballz]
67

I experimented with this in an attempt to make game-type mice, but ended up with a strange meccano-mix cat with partial robo-cat tendencies. Fun, but not a mouse :-) This basically tells the game how many basic ballz a breed has. Catz and Dogz are expected to have 67, mice are expected to have 16, as are cockroaches. But they also use different .scp, .bhd and .bdt files, which contain the basic information on the shape and behaviours the game expects to see in a certain type of breed. So if you change the number of ballz, the game tries to fit those into the shape dictated by those binary files. Yes, I've tried swapping those .scp, .bhd and .bdt files around, too, with consequently hilarious mad-scientist results.


[Omissions]

Example:
[Omissions]
65 eBall_zorient, // 65
66 eBall_ztrans, // 66
37
67 utility addball for andrew
68 utility addball for andrew
69 utility addball for andrew
70 utility addball for andrew
71 utility addball for andrew
72 utility addball for andrew
73 utility addball for andrew
74 utility addball for andrew
75 utility addball for andrew
76 utility addball for andrew

[Omissions] is your _friend_. Love it; hold it close; make easter-bunnies for it. With [Omissions] you need never worry about the disappearing toyz when headless petz pick them up, because the head and associated ballz are still a reasonable size, they are simply "omitted" from the screen. Don't use -999, use [Omissions], yeah baby!

It's interesting that ball 37 is always omitted in the base catz breedz. All the other ones listed here are simply orientation balls. If you don't list them, they will pop up like my mystery-emoticons at times of excitement; that's how I made my chickenz and turkeyz lay "eggz".

Now, if you want to omit any other ball, just list it under the ones that are already there:

14
15
16

and so on. You can do this with [Add Ball] balls also, and in fact this is the best way of making variations with [Add Ballz]; simply make a series of "#" variations under [Omissions] and list the unwanted ballz for each variation under the appropriate # number.


[Outline Color Override]

This is where you put variations for outline colours, and the most common to see here is the iris outline. For some reason, the iris outline is one of the most common problems that catch newcomers to petz hexing.

NOTE: if you don't have a variation number with no data at all between it and the next variation number, then the [Ballz Info] outline colours won't ever be able to show through for the listed ball outlines.

The first column contains the ball number, and the second column contains the colour number.


[Paint Ballz]

[Paint Ballz]
;base ball diameter(% of baseball) direction color outlinecolor fuzz outline group texture

base ball -- The ball to which you wish to apply the paint spot or patch

diameter(% of baseball) -- The diameter of the spot or patch, as a
percentage of the base ball

direction -- The x,y,z co-ordinates of the spot or patch relative to the centre of the base ball.
NOTE: The game doesn't like it if you try to make the ball 0,0,0, due to the way that the co-ordinate system works - (If you're interested: The three numbers should specify a normalized vector. A normalized vector is a vector with a unit length of 1 and is used to specify a direction. The only vector which *can't* be normalized is 0,0,0, since it has a length of 0, not 1. The game will end up storing these results as positive and negative infinity due to the calculations involved).

color -- Colour of the paint patch or spot. Note that colours 0-9 inclusive and 150 upwards are "opaque" and will not allow textures to show.

outlinecolor -- Outline colour of the patch or spot

fuzz -- Fuzziness of the patch or spot

outline -- Outline thickness

group -- The group which this spot or patch belongs to. If it's -1 it is "group-less" and there can be no mutations of this spot when breeding.

texture -- The texture which you wish your paint patch to have. -1 will give the patch no texture.
NOTE: The texture does not work in the same way as for Add Ballz, Ballz Info ballz, or Color Override ballz. You will usually find that the number in the texture column refers to a base ball which has the required texture. Remember, though, that if you have a texture number in here that is, say, 13, you _must_ have 14 textures in the Texture List or the game will most likely crash when a pair tries to breed. Sometimes the game isn't very clever...

Sometimes there is an extra column after Texture, as with this, for the Great Dane:

;snout spot
56, 70 -.8, -.8, -1 45 15 4 -1 0 1 0
56, 70 .8, -.8, -1 45 15 4 -1 0 1 0

As I understand it, this is a "scale hack". It seems that even the programmers had to frig some things to make them work right :-)

NOTE that Add Ballz have a limit of the number of ballz allowed before the game crashes. I have not yet come across a limit in Paint Ballz; even when I went up to 900, the pet was adoptable and could wear shirts, pants etc.


[Project Ball]

Example:
;stationary ball, projected ball, amt
[Project Ball]
43, 44, 120

There are three columns. The first is the ball to which another is going to relate -- it's the ball which will remain "stationary" -- and the second is the ball which is going to project from it by a certain amount, the third column being that amount (Written as a percentage of the original distance between the two balls). Because it uses one ball to steady another and keep it in the same relative distance, I tend to call this "anchoring". I believe that has confused people in the past.

[Project Ball]
;tail
43, 44, 120
44, 45, 120
45, 46, 120
46, 47, 120
47, 48, 120

Here's a tail in catz. The ballz are distanced from each other by quite a large amount; Ball 43 is holding ball 44 at a distance of 120%, and so on. Now here we would have a much shorter tail:

43, 44, 10
44, 45, 10
45, 46, 10
46, 47, 10
47, 48, 10

Of course for a manx look you could make the distance 0, but really it's best to list the tail ballz under [Omissions].

One thing which will be a big annoyance to breeders is the fact that, for 2nd-gens, it really matters a lot in what order the game uses the lines of data in [Project Ball]. This is what causes jumbled heads in my 2nd-gen chickenz; although I have the data in the breedfile entered in the correct order to achieve the effect that I want, when the game comes to create 2nd- gen pets it puts that data into the petfile in a slightly different order. Same exact data, different order, creates a different-shaped pet. So if the 2nd-gen thing matters to you, you'll need to make sure that this section is created such that whatever alterations to it the game makes in a 2nd-gen will result in the effect you want.


[Sounds]

Example: [Sounds]
\ptzfiles\cat\ca\casnd.txt

Of course ca\casnd.txt is different for different breedz. This lets you change your breed's sounds to anything you want. What you need to do is to create a sounds .txt file (I won't go into that here, as it's not part of the .LNZ, but I do talk about it in other "howto"s) and suitable sounds, put them into a directory on your hard drive off your game's catz or dogz directory (for example zixsn.txt in a directory called zix), and change

\ptzfiles\cat\ca\casnd.txt

to

\resource\catz\zix\zixsn.txt


[Species]

Examples:

[Species]
1

for Dogz:
[Species]
2

for Babyz:
[Species]
3

There is limited fun to be had with this, but try swapping a catz species for a dogz one or vice versa...


[Spot Factor]

I have never seen a pet which makes use of this. The idea is obviously that it helps control the markings on petz, but I have not found a syntax yet which makes any appreciable difference.


[Texture List]

Example:
; First argument is name of texture.
; Second argument is whether texture is single color (1) or multi-color (0)
; This texture list is used both here and in add ballz
[Texture List]
\art\textures\hair6.bmp 1
\resource\catz\scott1.bmp 0

In order to see a texture on a ball, your ball's colour has to be in the "non-opaque" range. That means, choose any colour from 10 to 149 inclusive. Any other number will not show a texture. If you put any number other than 1 or 0 here, such as 65, that number should indicate which colour in the "background" part of the texture will allow your ball colour to show through.

And a special note for the Wizard texture bitmap; for some magical reason, clever colour-changes which work on some people's machines do not work on other people's machines. The Wizard texture itself is identical, byte for byte, between all the games Petz 3, 4 and 5, and I've checked with different versions of the games. The problem does seem to be machine-specific, not game-specific or Operating-system specific.

If you are using a texture which is not one of the game's originals, you need it to be 256-colour, it must be in a directory on your hard drive which matches the address in the texture list, and for Petz 5 it must be 32x32 pixels or multiples thereof (not exceeding 128x128 pixels).

If you want the left ankle to be brindled in the Sheepdog, do the texture list like this for example:

[Texture List]
\art\textures\hair10.bmp 1 <-- this is texture number 0; the colour "argument" is 1
\art\textures\redrib.bmp 1 <-- this is texture number 1; the colour "argument" is 1
\art\textures\hair6.bmp 0 <-- this us texture number 2; the colour "argument" is 0

So that you have hair6.bmp in the list with its colour argument set to 0. Then change the number in the texture column of the left ankle in the Ballz Info, since you want to use the third texture (number 2):

;col outCol spklCl fuzz otlntTyp sizeDif group texture ball#
[Ballz Info]
25, 244, -1, 5, -1, 8, 4, 2 0 ;L ankle

And you would change the number in the texture column to 2 for every ball you wanted to be brindled.

I found that "60" was a good number to use for the "colour argument" if you want your background ball colour to show through and still keep the brindle effect:

\art\textures\hair6.bmp 60

it allows the ball colour through where the bitmap background is colour 60.


[Thin/Fat]

This is where you control the limits of how fat or thin your breed's pets can become.
There are three columns, one of which is the ball number, and the other two are the limits of thinness and fatness. Just fool around with these until you get them the way you want them.

As an example, take a Calico cat. Normal for this would be:

[Thin/Fat]
4, -15, 15
5, -15, 15
7, 0, 6
2, -10, 25
6, -10, 10
3, -10, 10
43, -5, 15
44, -5, 10
45, -5, 10
46, -5, 10
47, -5, 5
48, -5, 5
36, -10, 10
12, -10, 15
13, -10, 15
38, -10, 20
39, -10, 20
25, -10, 10
26, -10, 10
32, -10, 10
33, -10, 10
0, 0, 10
1, 0, 10

Well, if you want your adopted cats to look really peculiar if they are very thin or very fat, change those to:

[Thin/Fat]
4, -75, 75
5, -75, 75
7, -70, 76
2, -70, 85
6, -70, 70
3, -70, 70
43, -65, 75
44, -65, 70
45, -65, 70
46, -65, 70
47, -65, 65
48, -65, 65
36, -70, 70
12, -70, 75
13, -70, 75
38, -70, 80
39, -70, 80
25, -70, 70
26, -70, 70
32, -70, 70
33, -70, 70
0, -50, 70
1, -50, 70

When 100% fat, your pet will be a cute set of blobs, and when thin it will be a thin sausage with a skinny head and disconnected feet. Obviously you would not want to be as extreme as that, LOL. Also you can add in other ball numbers; whatever ballz you want to have become fat or thin when the cat is overfed or starving, just add them in with your own idea of how big and little they should become.

The same applies to dogz and babyz of course. If you want your pets or babyz never to become too fat or too thin, this is the place to make that happen.


[Whiskers]

Previous Top

If you try to make them -999, or list them in [Omissions], they simply won't go away. The simple solution is to put

[Whiskers]

with no data beneath it. They will disappear.

Normally, however, some or all of the whiskers are defined:

[Whiskers]
;start, end, color
30, 57, 248
30, 58, 248
30, 59, 248
31, 60, 248
31, 61, 248
31, 62, 248

The first column is the ball at which the whisker-line starts, the second is where it ends (the whisker ball), and the third column is the colour. You don't actually need to put the colour in. If you list only _some_ whiskers, the others will disappear. If you want to change the length of the whisker, you do it in [Project Ball].

Adding the [Whiskers] section to dogz has no appreciable effect. You really need to do whiskers the way they are done in the chihuahua if you want them.